Fast Socks5 server

05 Mar 2019 / admin
Dante socks5 server (v1.3.2) auto-install and management script

source - https://github.com/Lozy/danted



Install

wget --no-check-certificate https://raw.github.com/Lozy/danted/master/install.sh -O install.sh 
bash install.sh

# run with options: bash install.sh option1 option2
bash install.sh --ip="A.A.A.A:B.B.B.B" --port=2016 --user=sockd --passwd=sockd --whitelist="X.X.X.X/32"
  • if you want to uninstall, using this command
bash install.sh --uninstall
  • if you want to add user
/etc/init.d/sockd adduser USERNAME PASSWORD

Options

Long Option Short Option Value refer description
--ip=
ip address list (a.a.a.a:b.b.b.b) *#change ';' to ':' * Socks5 Server Ip address
--port=
Default: 2016 port for dante socks5 server
--user=
Pam-Auth Username Socks5 Auth user
--passwd=
Pam-Auth Password Socks5 Auth passwd
--whitelist=
whitelist ip range (a.a.a.a/32:b.b.b.b/32) Socks5 Auth IP list
--whitelist-url=
online white list file (url) Socks Auth whitelist http online
--from-package -p -- Install package from Bin package
--update-whitelist -u -- update white list
--force -f -- force install sockd
--help -h -- print help info

Management

command option description
service sockd start /etc/init.d/sockd start start socks5 server daemon
service sockd stop /etc/init.d/sockd stop stop socks5 server daemon
service sockd restart /etc/init.d/sockd restart restart socks5 server daemon
service sockd reload /etc/init.d/sockd reload reload socks5 server daemon
service sockd restart /etc/init.d/sockd restart restart socks5 server daemon
service sockd status
systemd process status
service sockd state /etc/init.d/sockd state running state
service sockd tail /etc/init.d/sockd tail sock log tail
service sockd adduser /etc/init.d/sockd adduser add pam-auth user: service sockd adduser NAME PASSWORD
service sockd deluser /etc/init.d/sockd deluser delete pam-auth user: service sockd deluser NAME

Test Pass

OS release Platform Provider Result
Debian GNU/Linux 8 (jessie) x86_64 vultr pass
Debian GNU/Linux 7 (wheezy) x86_64 vultr pass
Debian GNU/Linux 7 (wheezy) i686 vultr pass
Ubuntu 16.10 (Yakkety Yak) x86_64 vultr pass
Ubuntu 14.04.5 LTS i686 vultr pass
CentOS Linux 7 (Core) x86_64 vultr pass
CentOS Linux 6 x86_64 vultr pass
CentOS Linux 6 i686 vultr pass

Открытие сайтов из списка через VPN на Mikrotik/RouterOS

09 Jul 2018 / admin

Задача:

Открыть определенные сайты через VPN канал.

Все команды пишем в терминале WinBox.

И так, у Вас уже есть активный VPN клиент с названием, например, USAvpn - является названием интерфейса.

Создаем address-list на mikrotik с названием vpn-access, в который в дальнейшем будут добавляться IP адреса или домены.

/ip firewall address-list add address=2ip.ru list=vpn-access

В address пишем домен или ip. Для теста подойдет 2ip.ru.
В list пишем имя адрес листа, т.е. в нашем случае vpn-access.

Далее по очереди пишем в терминале:
Все, что отмечено жирным шрифтом, заменяем на свои названия, если они другие.

/ip firewall nat add action=masquerade chain=srcnat out-interface=USAvpn
/ip route add dst-address=0.0.0.0/0 gateway="USAvpn" routing-mark=vpn-access
/ip firewall mangle add action=mark-routing chain=prerouting dst-address-list=vpn-access new-routing-mark=vpn-access passthrough=no

Теперь заходим на 2ip.ru. Если IP адрес изменился, то значит правила работают и можно добавлять остальный сайты :)

Если через некоторое время трафик сайтов из списка vpn-access перестает идти через ваш vpn, то проверьте маршрут (IP > Routes) 0.0.0.0/0 на gateway с именем вашего VPN клиента. Маршрут нужно включить.

Быстро поднимаем IPSec сервер на CentOS

07 Jun 2018 / admin

В терминале вводим

wget https://git.io/vpnsetup-centos -O vpnsetup.sh && sudo sh vpnsetup.sh

По окончанию установки будет сгенерирован логин/пароль.

Добавить юзеров можно с помощью:

vi /etc/ppp/chap-secrets

(нужна перезагрузка)


vpnsetup.zip



1